AC/Heater Control Unit | Challenger Life Forums

AC/Heater Control Unit

Discussion in 'Dodge Challenger Electrical Problems and Questions' started by ONE L COOL J, Dec 2, 2019.

  1. ONE L COOL J

    ONE L COOL J New Member

    Joined:
    Dec 2, 2019
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Hey everyone,

    I just bought a used 2009 Dodge Challenger SE. A couple weeks after buying it, I noticed the AC/Heater Control unit with the 3 dials stopped working.

    I tried setting the blower on low, med, and high. Nothing. Tried cold air, hot air, and different defrost settings. Nothing. Even when I press the circulate air, AC, and rear defrost buttons they don’t light up. No air blowing whatsoever.



    I've tried all of the tips I've read online ~

    - Unplug negative battery cord for 15min. Plugged back in. Started car. AC/Heater Control unit still not working (none of the dials or buttons)

    - Removed every single 10AMP fuse (including 30AMP #42, and #43) from the rear fuse box. Waited 10min. Bought brand new 10AMP fuses and put those back in. Started car. AC/Heater Control unit still not working (none of the dials or buttons)

    - Removed AC / Heater Control Unit and checked wires/connectors. All good (no burn smell/marks). I Unplugged them all and plugged back in for safe measure. Started car. AC/Heater Control unit still not working (none of the dials or buttons)

    I called Dodge to see if they have the AC/Heater Control unit in stock (55111904AE). Apparently they stopped making this part for Challengers made in '08 & '09.. I asked them where I could find it, they said Autozone, O'Reilys, or Napa. I called all of the local auto stores, but they all said they don't carry the part or ever will. No junkyards have a Challenger in my year, which I need because apparently the AC/Heater Control units for 2010+ Challengers are a different. Rock Auto, Summit Racing, all the Mopar part websites don't have it.. Literally my only hope is a used one off eBay. There are literally 3 left in the nation (online).

    Unfortunately the part won't arrive until December 11th.. So I won't have a car for 2 weeks. Hopefully that used AC/Heater Control unit fixes my problem. If not I believe the only other 2 things it could be are my Heater Blower Resistor or one of the 3 Actuators. Really bummed out how this happened right after I bought the car.

    Does anyone know if the AC/Heater Control unit for 2010+ Challengers will fit in my 2009? I've read that they do, but for some reason the AC doesn't work. May be able to live with that. I live in Seattle, WA.

    I have an appt w local Dodge dealership this TUE AM for a diagnostic.
     
  2. ONE L COOL J

    ONE L COOL J New Member

    Joined:
    Dec 2, 2019
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Bump!
     
  3. IntimidatorR/T

    IntimidatorR/T Challenger Life Moderator Staff Member Ride of the Month

    Joined:
    Sep 12, 2009
    Messages:
    5,432
    Likes Received:
    154
    Trophy Points:
    63
    Location:
    Rosepine, Louisiana
  4. ONE L COOL J

    ONE L COOL J New Member

    Joined:
    Dec 2, 2019
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Just wanted to give a final update on this, in case anyone else runs into this problem.


    I want to Bud Clary Auburn Chrysler Dodge Jeep Ram here in Auburn, WA for a diagnosis.


    They quoted me $3,500 to repair my problem lol.


    • Rear power distribution center 5081730AG (rear fuse box)
    • Rear power harness (that goes to all electrical in cabin)
    • $600 (only available off vintage)

    15hrs of labor $2,600 (remove trunk, seats, carpet, rewire electrical)

    Told me there was an intermittent short and when they would move rear fuse box around you could hear the relays clicking on and off lol.


    I couldn't believe this is what they were quoting me. I told them I will just pay for the diag fee ($150) and the part that was needed ($600). When I picked my car up, my trunk liner had a dent in it where the rear driver wheel well is. Not a big deal, it can just be popped out. But 2 other things that were weird that were never a problem in my car prior to bringing it in


    1. all of a sudden i'm having problems pumping gas. stops every 4 gallons when pumping. (see my other thread)


    2. one of my sunroof drain tubes came unplugged and started causing my head liner to get soaked. I was able to remove my headliner and spot this and plug it back in. Just makes you wonder..


    Not saying they caused these problems, but it's very weird how 'new' issues came up after my visit. It was very obvious they were trying to take advantage of me with the diagnosis as well...


    After I left I brought my car over to a friends house who is a Tech for Honda. I told him the diagnosis and he inspected the rear fuse box a bit more. He noticed the connectors were pretty rusty, maybe from moisture damage. He cleaned them out, and spent a bit more time on the connectors for the fuses that control the HVAC unit. This didn't work. Then he tested connectors for power and noticed the ones that were in charge of powering the fuse for the HVAC was not receiving power. We checked the associated relay and noticed that it was rusted/corroded. Went to Auto Zone, bought a replacement relay for $20, plugged it in and my HVAC unit works again. All it took was an hr inspection from an experienced mechanic and a $20 replacement part.


    I went back to Bud Clary Auburn Chrysler Dodge Jeep Ram and spoke to the GM first thing in the morning. Told him the entire story and showed him the old relay that was replaced. He refunded me for misdiagnosis and the $600 special order part.


    Be careful dealing with dealerships!
     

Share This Page