Challenger Life Forums banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
3,505 Posts
Discussion Starter · #1 ·
So I went into the dealer today to pick up my start button (that was missing at delivery) and most of my Mopar accessories.

I remember why I like this dealership.... everyone is very nice and very helpful. My salesperson, Laura, even stopped by the service bay to talk for a bit.

They did think that they needed to program the push to start button so it would work with my car though..... till I pulled the one I bought on eBay out of my pocket and said "this one from eBay works fine, it's just a plastic button." lol
 

·
Registered
Joined
·
2,557 Posts
So guess we know which button u got first! Did u get the other Mopar stuff installed yet, or is it still there now?
 

·
Premium Member
Joined
·
3,505 Posts
Discussion Starter · #3 ·
It was almost a tie. The day the button came in the mail, the dealer called and said they had my button in. I just didn't see a reason to go to the dealer till they had more of my parts in.

Still waiting on the sill guards and CAI. The hood struts and cargo/floor mats are installed - they were too easy. Planning on the LED lighting some time this week.
 

·
Registered
Joined
·
2,557 Posts
Hope I don't lose rep points for this, but here goes! Got plenty of TIME now to remove the HOODPROP! Don't post any engine bay pictures with that thing on, or I'LL rag u boss!!!!!!!!( thats what us scooter tramps call a subtle F hint to the REST, tee hee!)
 

·
Premium Member
Joined
·
3,505 Posts
Discussion Starter · #5 ·
Hope I don't lose rep points for this, but here goes! Got plenty of TIME now to remove the HOODPROP! Don't post any engine bay pictures with that thing on, or I'LL rag u boss!!!!!!!!( thats what us scooter tramps call a subtle F hint to the REST, tee hee!)
Already in the plans.... :thumbupright:
 
1 - 5 of 5 Posts
Top